Map color reversed in plan views

When I add a map to a plan view the colors become reversed. I've fiddled with every control I can think of and read the documentation, but I just can't get the colors to come out correctly. How can I get the correct colors to display?

Here's what the map looks like in the scene view:


And this is what it looks like in the plan view layout:

This image is not draped on topography and has 100% opacity. No other objects are in the plan view layout.


Answers

  • JosephParker
    JosephParker Posts: 8 mod
    edited January 17

    Hi Charles,

    I can't seem to replicate the problem you are having there!

    I've tried on our internal maps and images and also tried downloading the image from your post and it seemed to have worked ok (But that was likely just a screen snip of the actual map - see below).

    Would it be possible to grab a copy of the map you are trying to display on your plan view and we'll take a look? I believe you can attach it in the comments section, alternately, you could try emailing it to [email protected], please copy the URL for this page in the email for context :)

    Other info that might be handy to include:

    • Which product (Leapfrog Geo/Edge/Energy) are you using and which version?
    • Does this happen on other maps? (if you have tried others)
    • Are you using a "non-white" background in the scene view? If there are any transparent areas of the map then this would cause the map to look different in the layout view which has a white background
    • In case you haven't already, check the lighting setting in the scene view. Leapfrog Menu>Settings>Lighting. It could be that the image is very dim in the scene view but showing correctly in the plan layout

    If you want to resolve this right now, a workaround I might suggest is:

    • Load the image into the scene view
    • Use the Render Image button to create a new map of the scene view. If the button is not active in your toolbar you can access it from the Leapfrog menu
    • Save the rendered image and reimport it back into the GIS Data, Maps and Photos folder.
    • At the georeferencing step, use the original map to help georeference the rendered map. Choose location like the mountain, rivers or roads to tie in the rendered image to the original image

    If you are running Leapfrog 2023.2 onwards, you can skip the manual georeferencing and create a "New Rendered Map" https://help.seequent.com/Geo/2023.2/en-GB/Content/data/images.htm?Highlight=rendered%20map#rendered-map


  • The file is very big. I'll send a download link to the support email.

    Answers to other info:

    1) I'm using Leapfrog Works 2023.2.1

    2) Yes, this does seem to happen with other maps in this project. I haven't tried other project yet.

    3) The background is the default very dark blue. Opening the file (a TIF) in an external viewer does not show any transparent areas.

    4) Changing lighting settings didn't seem to change anything.

    Since my first post I've had some time to fiddle with this. Here's what I found, but remember these "clues" may be completely useless.

    1) When I was trying to correct the final PDF using PDF Exchange editor, I was able to restore the image to its proper colors by choosing "Delete mask from image" option on the recompress dialog window:

    I have no idea what that really does. I can't find it documented in the PDF Ex help.

    2) If I open the original TIF with Windows Photo Viewer (outside of leapfrog) and zoom in, the colors invert like I initially reported in my plan layout. The colors are normal until a certain zoom point is reached and then they invert. If I open the same file with the Photos App (on Windows 10), then the color inversion doesn't happen at all, regardless of zoom level.

  • JosephParker
    JosephParker Posts: 8 mod

    Hi Charles,

    Thanks for the additional info and thank you for sending us the file. We are downloading it now (you're right, it's quite big!) and will take a look for you and let you know what we find out

  • JohnTyrrell
    JohnTyrrell Posts: 3
    edited January 17

    Good Morning Charlie,

    I have looked at the TIFF file you linked for download and loaded it into Leapfrog. I am getting the same issue with colours changing when draped onto a mesh. I think the problem is that you have an Alpha Channel saved into the file, which gives it variable transparency.

    I opened the TIFF in Gimp (Photoshop equivalent) and can only see one layer, so it can't be modified as is. Can you open the original image in the application that exported it and remove the Alpha Channel layer? If so, then reloading it into Leapfrog should resolve the issue.

    I will also notify the development team to see if there is any way we can integrate better importing this type of file in future revisions of Leapfrog. 

    Regards, ​​​​​​​John Tyrrell

    Senior Project Geologist, Seequent

  • Thanks for figuring out that alpha is the culprit. This GeoTIFF came to me via others, so I have no idea what it was created in. However, I was able to get it working by deactivating the alpha channel and copying over the georeference data. Here's what I did for anyone else with this issue. (I'm using linux below, but there are equivalents on Windows).

    Deactivate the alpha layer using ImageMagick:

    convert very_big_image.tif -alpha deactivate very_big_image_no_alpha.tiff

    (Since this was a very big image I had to tweak the imagemagick settings in /etc/ImageMagick-6/policy.xml)

    The difference is even apparent in the windows file explorer icons: (alpha on left, deactivated on right)


    For some unknown and annoying reason, imagemagick deleted the georeference data headers. I could re-reference it manually in Leapfrog, but where's the fun in that? Copy them from the original file to the new alpha-less file with:

    exiftool -tagsfromfile very_big_image.tif -GeoTiffDirectory -GeoTiffDoubleParams -GeoTiffAsciiParams -PixelScale -ModelTiePoint very_big_image_no_alpha.tiff

    It took a while to figure out I needed to copy the PixelScale and ModelTiePoint tags in addition to the rest of the GeoTiff tags. PixelScale and ModelTiePoint were stored as regular EXIF type tags, not the special GeoTiff tags.

    Hint: You can inspect the tags with: exiftool -D -G -a -u -U -f very_big_image_no_alpha.tiff

  • Hi Charlie,

    I have looked at the TIFF file you made available in Gimp again and played with a couple of options. If you just disable the alpha channel in Gimp, then save (export) the file as a TIFF again it causes the same behaviour as when you drape the image on a mesh. Gimp applies the alpha channel when you disable it!

    If you open the file in Gimp and select the Alpha channel, you can alter the transparency. I used the Curves option. In the right hand sidebar, where the brushes and layers options are, you make the Channels visible. At the bottom of the stack you should see an Alpha channel, under the blue, green and red ones. Highlight the Alpha channel, then using Curves (or some other method) make it all white by dragging the control points. If you make it all white it is full opacity. 

    Exporting the file as a TIFF now will preserve all of the original colour information as there is effectively no transparency. This option also allows you to save all of the original Metadata, including Geo-referencing, if present.

    Gimp is free., open-source software and works with Linux. MacOS and Windows. The same process can be applied in Photoshop and probably PaintShop Pro and other image programmes as well.

    ​​​​​​​Regards, John