Has anyone face an error while trying to update the geological model extent?

I am following the Leapfrog Geothermal online self learning course, and while trying to update the geological model extent, I encountered this error:
RBF fitter reached internal max iteration count
does anyone knows how to fix this one?


  • JoelVergunst

    The usual cause for this error is when a lot of data and/or conflicting data is been used to create a surface.
    You could try to:

    • 1: Filtering/ cleaning the data that you are using to create the surface, and/or
    • 2: Reduce the resolution of the surface

    This could be related to duplicate data or the data is too dense for the algorithm to create the surface. This support article (Error: "RBF Interpolation failed to converge. Check the accuracy. If using a Spheroidal interpolant, a smaller range or larger nugget value may help".) is related to numeric models but essentially the process is the same. Alternatively, please check that after opening the configuration window to edit the Stratigraphic sequence lithologies there is an option box called "Surfaces avoid well segments" which may be active, and once deactivated this may resolve the issue.

    I have seen this resolved before when there was an errant point causing the problem, which once deleted solved the issue.

    Try these suggested methods and see how it goes.