Automatic interpolation on opening grids?


I have an issue with making a constraint grid for 3D gravity inversions. I have made a blank grid with all values 1 in Oasis, then edited an area of it to be 0 in Arc. I then want to re-import it into Oasis to use, but opening it appears to do some sort of smoothing/interpolation between cells in an attempt to increase resolution? Can I stop it from doing this?

It wouldn't matter too much, but this seems to introduce errors - a couple of pixels now have negative values, and when I try to use the grid as a constraint I get an error message saying it contains dummies. Metadata > Grid statistics however says there are no dummies. I've tried various fill dummy options, which mostly made things worse, and tried regridding, which seemed to work but also changed the size of the grid so it was no longer valid for the 3D model. I then tried to window that grid and Oasis reintroduced the smoothing and negative values!

I have also tried importing in a couple of different file formats and converting formats within Oasis, all to no effect.

Thanks for any help.


  • AlistairStronach
    AlistairStronach Posts: 7 Calcite Rank Badge
    edited July 2020
    Hi Natalie,

    Thanks for the quick reply - The no smoothing option is good thanks, that shows there are not actually any negatives in the grid. Must have been some artifact of the smoothing.

    However, no success in getting the gravity inversion to run - tried saving as a database and there appeared to be no dummies or errors. Then used direct gridding and again the output grid showed no dummies in stats. Gravity inversion though still gives "Grid contains dummies" error. Can't see what the issue is!

    Edit: Solved it. I've imported the shapefile I made in Arc and used that to mask the blank grid in Oasis, rather than importing the grid from Arc. The resulting grid worked for the inversion.. Don't know why the other grids were not working though, it appeared identical.
  • GerryConnard1
    GerryConnard1 Posts: 6 Staff
    One possibility is that the constraint grid you created does not match the grids in your model exactly. GM-SYS 3D re-interpolates the input grid to match the model. That may be causing the problem.